Hola soy jilo
quisiera pasar un pseudo codigo a visual basic 6.0 archivo secuencial for random.


Código:

Dado el fichero secuencial ARTICULOS.DAT, cuyos campos son: NART,
ARTICULO, PVP, STOCK y MINIMO. En otro fichero VENTAS.DAT, est n
almacenadas las modificaciones de los productos durante el día, cuyos
campos son: NART2, VENTAS y TIPO. El campo TIPO puede tomar los valores 0
(venta) y 1 (compra). Se desea hacer un programa que realice una
actualizaci¢n del fichero de ARTICULOS y un listado por impresora de las
entradas y salidas de los art¡culos.


ENTORNO:
   entra <- 0
   sale <- 0
   total <- 0
   fi <- 55
   sw <- 0
   aux <- 0
   pag <- 1
ALGORITMO:
   Borrar_pantalla( )
   Activar_impresora( )
   ABRIR "ARTICULOS.DAT"
   Primer_registro( )
   ABRIR "SALIDAS.DAT"
   Primer_registro( )
   ABRIR "VENTAS.DAT"
   Primer_registro( )
   SELECCIONAR "VENTAS.DAT"
   MIENTRAS NO Eof( ) HACER
      SI fi = 55 ENTONCES
         HACER Cabecompras
      FINSI
      SI sw = 0 ENTONCES
         aux <- nart2
         HACER Buscar
         sw <- 1
      FINSI
      SI nart2 = aux ENTONCES
         HACER Calculos
      SINO
         HACER Grabar
         HACER Compra
         entra <- 0
         sale <- 0
         aux <- nart2
         HACER Buscar
         HACER Calculos
      FINSI
      Siguiente_registro( )
   FINMIENTRAS
   HACER Grabar
   HACER Compra
   SELECCIONAR "SALIDAS.DAT"
   fi <- 55
   MIENTRAS NO Eof( ) HACER
      SI fi = 55 ENTONCES
         HACER Cabesal
      FINSI
      MIENTRAS nart3 <> nart HACER
         SELECCIONAR "ARTICULOS.DAT"
         Siguiente_registro( )
      FINMIENTRAS
      aux <- nart3
      HACER Buscar
      HACER Sale
      SELECCIONAR "SALIDAS.DAT"
      Siguiente_registro( )
   FINMIENTRAS
   EN fi + 4,55 ESCRIBIR "Total: "
   EN fi + 4,62 ESCRIBIR total
   Activar_pantalla( )
   Cerrar_ficheros( )
   BORRAR "SALIDAS.DAT"
FINPROGRAMA
------------------------------
SUBPROGRAMA Calculos
   SI tipo = 0 ENTONCES
      entra <- entra + ventas
   SINO
      sale <- sale + ventas
   FINSI
FINSUBPROGRAMA
------------------------------
SUBPROGRAMA Grabar
   stock <- stock + entra - sale
   SELECCIONAR "ARTICULOS.DAT"
   Escribir_registro( )
   nart3 <- aux
   ventas3 <- sale
   SELECCIONAR "SALIDAS.DAT"
   Final_fichero( )
   Escribir_registro( )
FINSUBPROGRAMA
------------------------------
SUBPROGRAMA Cabecompras
   Salto_pagina( )
   EN 2,65 ESCRIBIR "P g.: "
   EN 2,71 ESCRIBIR pag
   EN 4,20 ESCRIBIR "LISTADO DE LAS ENTRADAS DE ARTICULOS AL DIA: "
   EN 4,66 ESCRIBIR Fecha_sistema( )
   EN 6,18 ESCRIBIR "N£mero"
   EN 6,35 ESCRIBIR "Art¡culo"
   EN 6,65 ESCRIBIR "Cantidad"
   EN 7,15 ESCRIBIR "----------------------------------------------------------------"
   fi <- 9
   pag <- pag + 1
FINSUBPROGRAMA
------------------------------
SUBPROGRAMA Compra
   EN fi,16 ESCRIBIR aux
   EN fi,30 ESCRIBIR articulo
   EN fi,67 ESCRIBIR entra
   fi <- fi + 1
FINSUBPROGRAMA
------------------------------
SUBPROGRAMA Cabesal
   Salto_pagina( )
   EN 2,65 ESCRIBIR "P g.: "
   EN 2,71 ESCRIBIR pag
   EN 4,20 ESCRIBIR "LISTADO DE SALIDAS DE ARTICULOS AL DIA: "
   EN 4,60 ESCRIBIR Fecha_sistema( )
   EN 6,8 ESCRIBIR "N£mero"
   EN 6,16 ESCRIBIR "Art¡culo"
   EN 6,40 ESCRIBIR "Cantidad"
   EN 6,54 ESCRIBIR "PVP"
   EN 6,64 ESCRIBIR "Importe"
   EN 7,6 ESCRIBIR "------------------------------------------------------------------------------"
   fi <- 9
   pag <- pag + 1
FINSUBPROGRAMA
------------------------------
SUBPROGRAMA Sale
   Salto_pagina( )
   SI stock < minimo ENTONCES
      EN fi,4 ESCRIBIR "*"
   FINSI
   EN fi,6 ESCRIBIR nart3
   EN fi,14 ESCRIBIR articulo
   EN fi,40 ESCRIBIR ventas
   EN fi,54 ESCRIBIR pvp
   EN fi,65 ESCRIBIR ventas * pvp
   total <- total + ventas * pvp
   fi <- fi + 1
FINSUBPROGRAMA
------------------------------
SUBPROGRAMA Buscar
   MIENTRAS nart <> aux HACER
      SELECCIONAR "ARTICULOS.DAT"
      Siguiente_registro( )
   FINMIENTRAS
FINSUBPROGRAMA

gracias.